This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH 2/2] Windows libcpp: Make path-exists semantics more Posix-like


On 04/19/2014 09:41 PM, Kai Tietz wrote:

> Isn't this function something better placed in libiberty?  Also this name looks a bit confusing.  Wouldn't be a an function calling for _WIN32 case also stat, and just overrides the st_mode member, if it is a link better.  So I would put this function to the file_... API of libiberty.

I'd even suspect that e.g., GNU Make / Makefiles would be likewise affected
by this.  A solution for this in gcc, or in a few selected programs
only, looks brittle to me.  Perhaps it should be mingw itself that provides
a _non-default_ replacement as option (similarly to __mingw_printf).

Can't glibc be changed to not rely on this?  /me hides.

-- 
Pedro Alves


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]