This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH, i386, MPX, 3/X] MPX tests


On Tue, 19 Nov 2013, Joseph S. Myers wrote:

> No, they should use { dg-add-options mpx } (well, both the directory name 
> and the dg-add-options argument should use whatever generic name for this 
> functionality we ended up with, rather than the name for the particular 
> instance of it on x86, so say gcc.dg/chkp and dg-add-options chkp).  The 
> add_options_for_chkp function should then check the target and add the 
> appropriate options depending on the target.

Of course, better than { dg-add-options chkp } in every test would be some 
generic code in a .exp file that arranges for the right options (still 
target-specific) to be added automatically for every test in the 
directory.

-- 
Joseph S. Myers
joseph@codesourcery.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]