This is the mail archive of the
mailing list for the GCC project.
Re: [wide-int] Make trees more like rtxes
- From: Richard Biener <rguenther at suse dot de>
- To: Richard Sandiford <rdsandiford at googlemail dot com>
- Cc: Mike Stump <mikestump at comcast dot net>, zadeck at naturalbridge dot com, gcc-patches at gcc dot gnu dot org
- Date: Thu, 24 Oct 2013 10:44:30 +0200 (CEST)
- Subject: Re: [wide-int] Make trees more like rtxes
- Authentication-results: sourceware.org; auth=none
- References: <87txg9cvzc dot fsf at sandifor-thinkpad dot stglab dot manchester dot uk dot ibm dot com> <alpine dot LNX dot 2 dot 00 dot 1310231057260 dot 11149 at zhemvz dot fhfr dot qr> <87eh7cqjsf dot fsf at sandifor-thinkpad dot stglab dot manchester dot uk dot ibm dot com> <71DA6B1E-E240-4520-B8E6-3497A8EB3EC9 at comcast dot net> <8738nr4rf6 dot fsf at talisman dot default>
On Wed, 23 Oct 2013, Richard Sandiford wrote:
> Mike Stump <email@example.com> writes:
> > On Oct 23, 2013, at 5:00 AM, Richard Sandiford
> > <firstname.lastname@example.org> wrote:
> >> offset_int, max_int, wi::to_offset and wi::to_max sound OK to me.
> >> Kenny? Mike?
> > Those two names seem reasonable. to_offset should document that these
> > are for address offsets (and address constants) exclusively.
> Reading this back, I realise "max_int" might sound too similar to INT_MAX.
> Maybe we could follow the current HOST_* stuff and use: offset_int, widest_int,
> wi::to_offset and wi::to_widest.
> Bah. I'm no good at naming stuff...
Nobody is ... but yes, offset_int and widest_int and wi::to_offset
and wi::to_widest sounds good to me - both short and descriptive.