This is the mail archive of the
mailing list for the GCC project.
Re: [wide-int] Make trees more like rtxes
- From: Mike Stump <mikestump at comcast dot net>
- To: Richard Biener <rguenther at suse dot de>
- Cc: Richard Sandiford <rsandifo at linux dot vnet dot ibm dot com>, zadeck at naturalbridge dot com, gcc-patches at gcc dot gnu dot org
- Date: Wed, 23 Oct 2013 12:29:46 -0700
- Subject: Re: [wide-int] Make trees more like rtxes
- Authentication-results: sourceware.org; auth=none
- References: <87txg9cvzc dot fsf at sandifor-thinkpad dot stglab dot manchester dot uk dot ibm dot com> <alpine dot LNX dot 2 dot 00 dot 1310231057260 dot 11149 at zhemvz dot fhfr dot qr>
On Oct 23, 2013, at 2:09 AM, Richard Biener <firstname.lastname@example.org> wrote:
> Good. Better names - ah well, wi::to_max_wide_int (t) and
> wi::to_addr_wide_int (t)? Btw, "addr_wide_int" is an odd name
The idea was to have one type to rule them all… everything address related... bit offsets, byte offsets… Bit offset is the wrong name, as that would be a wrong type to use for a byte offset. Someone that has a bit offset type, would naturally want to /8 to get a byte offset. If one wanted a bit offset, then it should be split into two, bit offset and byte offset.