This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] manage dom-walk_data initialization and finalization with constructors and destructors
- From: Jeff Law <law at redhat dot com>
- To: Richard Biener <richard dot guenther at gmail dot com>
- Cc: Michael Matz <matz at suse dot de>, Trevor Saunders <tsaunders at mozilla dot com>, GCC Patches <gcc-patches at gcc dot gnu dot org>, Richard Sandiford <rdsandiford at googlemail dot com>
- Date: Fri, 20 Sep 2013 11:16:14 -0600
- Subject: Re: [PATCH] manage dom-walk_data initialization and finalization with constructors and destructors
- Authentication-results: sourceware.org; auth=none
- References: <1378264562-30803-1-git-send-email-tsaunders at mozilla dot com> <CAFiYyc2WMqt7b=riv_3+LUDQ=+OjycgEqK+L8afjPcaVzU9Wag at mail dot gmail dot com> <20130904145911 dot GC17620 at tsaunders-iceball dot corp dot tor1 dot mozilla dot com> <522759C8 dot 5040802 at redhat dot com> <20130911000350 dot GA28492 at tsaunders-iceball dot corp dot tor1 dot mozilla dot com> <52389CB1 dot 60504 at redhat dot com> <5239126A dot 6010702 at redhat dot com> <alpine dot LNX dot 2 dot 00 dot 1309181640400 dot 9949 at wotan dot suse dot de> <5239D985 dot 4080205 at redhat dot com> <alpine dot LNX dot 2 dot 00 dot 1309181849550 dot 9949 at wotan dot suse dot de> <87fvt065ro dot fsf at talisman dot default> <CAFiYyc0xY9Wrn1MhWjM-u5L+OE583Yr4H5HedYi4yYaMOudp-Q at mail dot gmail dot com>
On 09/20/2013 02:13 AM, Richard Biener wrote:
That would be fine with me. If you want to propose this as a change to
our coding standards, I'd support it. Then it's just a matter of
changing the existing code.. Sigh..
On Thu, Sep 19, 2013 at 8:11 PM, Richard Sandiford
Michael Matz <firstname.lastname@example.org> writes:
What's the benefit of reading and writing such noisy lines? :
*out_mode = mode_;
mode_ = GET_MODE_WIDER_MODE (mode_);
The uglification merely makes code harder to write and read, it should be
used in cases where you _don't_ want developers to write such names.
Heh. Since it's my code being used as the example here: I also find it
very ugly FWIW. I only added the underscores because that's what the
But we're never going to get consensus on this kind of thing. E.g. I
know some people really hate the GNU formatting style (although I very
much like it). So I just held my nose while writing the patch.
Btw, I've come around multiple coding-styles in the past and I definitely
would prefer m_mode / m_count to mark members vs. mode_ and count_.
(and s_XXX for static members IIRC).