This is the mail archive of the
mailing list for the GCC project.
Re: [patch] Cleanup tree-ssa-ter.c exports
- From: Andrew MacLeod <amacleod at redhat dot com>
- To: Richard Biener <richard dot guenther at gmail dot com>
- Cc: gcc-patches <gcc-patches at gcc dot gnu dot org>, Diego Novillo <dnovillo at google dot com>
- Date: Mon, 16 Sep 2013 10:42:05 -0400
- Subject: Re: [patch] Cleanup tree-ssa-ter.c exports
- Authentication-results: sourceware.org; auth=none
- References: <52322D91 dot 8000706 at redhat dot com> <CAFiYyc3mcMJ9rU7YX2AOaAK_Qs7EzgRxe-X=pbEnkNf2czJCNw at mail dot gmail dot com> <52332B0A dot 7070602 at redhat dot com> <52336443 dot 3020100 at redhat dot com> <CAFiYyc130Z_Rmq84FH+qTNApJUhc=buT9=vXrihwVt2UFqQ_-g at mail dot gmail dot com>
On 09/16/2013 04:55 AM, Richard Biener wrote:
On Fri, Sep 13, 2013 at 9:15 PM, Andrew MacLeod <firstname.lastname@example.org> wrote:
OK, a slightly different take..
I realized that I should be adding tree-outof-ssa.h to handle the 3 exports
from tree-outof-ssa.c that are in ssaexpand.h... In fact, by far the most
sensible thing to do is to simply rename tree-outof-ssa.c to ssaexpand.c.
This actually resolves a number of warts... And is_replaceable_p() very
naturally fits in ssaexpand.c now...
what do you think of this option? :-) and svn rename preserves all the
I don't like the new name for tree-outof-ssa.c, it matches less to its contents.
I'd say either keep ssaexpand.h and tree-outof-ssa.c as-is or rename
ssaexpand.h to tree-outof-ssa.h. I prefer the latter.
I as well. ssaexpand.h ->tree-outof-ssa.h it is.
The rest of the changes look ok to me, but watch out for odd whitespace
+static inline bool
+ter_is_replaceable_p (gimple stmt)
+ if (ssa_is_replaceable_p (stmt))
spurious vertical space.
bah, where'd that come from :-P.
I'll check this approach in after running it through the gauntlet again.