This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Using gen_int_mode instead of GEN_INT minor testsuite fallout on MIPS


Mike Stump <mikestump@comcast.net> writes:
> Here is the patch to add precision to partial int modes.  I included
> switching over the rs6000 port to the new scheme so one can get a feel
> for that it would look like.
>
> I could trivially convert the remaining ports:
>
> config/bfin/bfin-modes.def:PARTIAL_INT_MODE (DI);
> config/m32c/m32c-modes.def:PARTIAL_INT_MODE (SI);
> config/msp430/msp430-modes.def:PARTIAL_INT_MODE (SI);
> config/rs6000/rs6000-modes.def:PARTIAL_INT_MODE_N (TI, 128);
> config/sh/sh-modes.def:PARTIAL_INT_MODE (SI);
> config/sh/sh-modes.def:PARTIAL_INT_MODE (DI);
>
> to the new scheme so that _all_ ports would have a precision with all
> partial int modes.  The newest port that I had not audited for how they
> use it (msp430):
>
> /* 20-bit address */
> PARTIAL_INT_MODE (SI);
>
> So, this, trivially would be SI, 20â I would define PARTIAL_INT_MODE
> with two parameters and not define PARTIAL_INT_MODE_N, if we did it for
> real.  No need for partial conversions here, too easy to convert things.

How about a three-operand version: the name of the partial mode,
the name of the memory mode, and the precision?  "PTI" and "P128TI"
are a bit confusing for the (hacky) powerpc usage, since 128 bits
isn't partial.  With three operands we could pick a more descriptive name.

Thanks,
Richard


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]