This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Go patch committed: Update libgo to 1.1.1


On Tue, Jul 16, 2013 at 5:45 PM, Ian Lance Taylor <iant@google.com> wrote:
> On Tue, Jul 16, 2013 at 6:07 AM, Uros Bizjak <ubizjak@gmail.com> wrote:
>>
>>> I have committed a large patch to update libgo to the library that was
>>> part of the Go 1.1.1 release.  As usual, I'm not including the entire
>>> patch in this e-mail message, because it is too large.  I'm only
>>> including the changes to the files that are partially gccgo-specific.
>>> Bootstrapped and ran Go testsuite on x86_64-unknown-linux-gnu.
>>> Committed to mainline and 4.8 branch.
>>
>> I have hit following build failure on non-USING_SPLIT_STACK target
>> (alpha-linux-gnu):
>
> Thanks.  Fixed like so.  Committed to mainline and 4.8 branch.

Thanks, with your patch, I was able to compile libgo without problems.
The testsuite run exposes a timeout in net/http, I am looking into it.

Another problem was triggered on CentOS 5.9, where compile fails with:

../../../gcc-svn/trunk/libgo/runtime/netpoll_epoll.c: In function
‘runtime_epollcreate1’:
../../../gcc-svn/trunk/libgo/runtime/netpoll_epoll.c:41:2: error:
implicit declaration of function ‘epoll_create1’
[-Werror=implicit-function-declaration]
  r = epoll_create1(flags);
  ^
cc1: all warnings being treated as errors
gmake[4]: *** [netpoll_epoll.lo] Error 1
gmake[4]: *** Waiting for unfinished jobs....

CentOS has glibc 2.5 and epoll_create1 is not supported.

Uros.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]