This is the mail archive of the
mailing list for the GCC project.
Re: [patch] trivial replacements for SET_INSN_DELETED and BLOCK_FOR_INSN as lhs
- From: Eric Botcazou <ebotcazou at adacore dot com>
- To: Steven Bosscher <stevenb dot gcc at gmail dot com>
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Tue, 02 Apr 2013 11:44:07 +0200
- Subject: Re: [patch] trivial replacements for SET_INSN_DELETED and BLOCK_FOR_INSN as lhs
- References: <CABu31nPcHNhATj33+VXv8zWe48eqS=rNxwjJJ6M3KazqaCHLVQ at mail dot gmail dot com> <9616370 dot 29AI8kKyeT at polaris> <CABu31nMADjdaTR+9ZV3QNy_mnmkBpaLLE3zvbPtWz99i9NX4AQ at mail dot gmail dot com>
> True, I don't like that bit very much myself, either. But I expected
> more resistance for the full change ;-)
Possibly. You might really want to wait until the end of the week. :-)
> Right. OK if I call it get_block_for_insn() and make the replacements?
get_block_for_insn will break formatting... just block_for_insn I'd say.