This is the mail archive of the
mailing list for the GCC project.
Re: [patch] trivial replacements for SET_INSN_DELETED and BLOCK_FOR_INSN as lhs
- From: Steven Bosscher <stevenb dot gcc at gmail dot com>
- To: Eric Botcazou <ebotcazou at adacore dot com>
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Tue, 2 Apr 2013 11:31:21 +0200
- Subject: Re: [patch] trivial replacements for SET_INSN_DELETED and BLOCK_FOR_INSN as lhs
- References: <CABu31nPcHNhATj33+VXv8zWe48eqS=rNxwjJJ6M3KazqaCHLVQ at mail dot gmail dot com> <9616370 dot 29AI8kKyeT at polaris>
On Tue, Apr 2, 2013 at 11:17 AM, Eric Botcazou wrote:
>> Using set_block_for_insn instead of using BLOCK_FOR_INSN is the "proper"
> Yes, but BLOCK_FOR_INSN as accessor around INSN_BASIC_BLOCK is ugly and a bit
True, I don't like that bit very much myself, either. But I expected
more resistance for the full change ;-)
> Either keep BLOCK_FOR_INSN or make the full change (the number of
> occurrences of BLOCK_FOR_INSN in the back-ends is surprisingly very small).
Right. OK if I call it get_block_for_insn() and make the replacements?