This is the mail archive of the
mailing list for the GCC project.
Re: [patch] trivial replacements for SET_INSN_DELETED and BLOCK_FOR_INSN as lhs
- From: Eric Botcazou <ebotcazou at adacore dot com>
- To: Steven Bosscher <stevenb dot gcc at gmail dot com>
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Tue, 02 Apr 2013 11:17:14 +0200
- Subject: Re: [patch] trivial replacements for SET_INSN_DELETED and BLOCK_FOR_INSN as lhs
- References: <CABu31nPcHNhATj33+VXv8zWe48eqS=rNxwjJJ6M3KazqaCHLVQ at mail dot gmail dot com>
> Using set_block_for_insn instead of using BLOCK_FOR_INSN is the "proper"
Yes, but BLOCK_FOR_INSN as accessor around INSN_BASIC_BLOCK is ugly and a bit
misleading. Either keep BLOCK_FOR_INSN or make the full change (the number of
occurrences of BLOCK_FOR_INSN in the back-ends is surprisingly very small).