This is the mail archive of the
mailing list for the GCC project.
Re: [patch] Normalize more bitmap function names.
- From: Lawrence Crowl <crowl at googlers dot com>
- To: Diego Novillo <dnovillo at google dot com>
- Cc: Richard Biener <rguenther at suse dot de>, gcc-patches List <gcc-patches at gcc dot gnu dot org>
- Date: Thu, 1 Nov 2012 10:41:01 -0700
- Subject: Re: [patch] Normalize more bitmap function names.
- References: <CAGqM8fatObp7ZvxZC9Ypq6=Q92pkyyQbPMwP-A9iU_x1=OX_aA@mail.gmail.com> <firstname.lastname@example.org>
On 11/1/12, Diego Novillo <email@example.com> wrote:
> On 2012-10-31 13:41 , Lawrence Crowl wrote:
>> This patch normalizes more bitmap function names.
>> TEST_BIT -> bitmap_bit_p
>> SET_BIT -> bitmap_set_bit
> I wonder if it wouldn't it be more consistent if TEST_BIT became
> bitmap_test_bit() ? I never particularly liked the lispy *_p
> convention. But I don't really care much one way or the other.
The plan was to simply use the bitmap names, and given the
schedule I would prefer to leave it as is.
> The patch is OK.
Okay. I will merge and commit.