This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [7/7] Tidy IRA move costs

On 05/30/2012 02:44 PM, Richard Sandiford wrote:
The previous patch asserted that the first and second sets are now the same,
which means that the second and (temporary) third sets are no longer needed.
This patch removes them and renames the first set to have the same names
as the second used to.


gcc/ * ira-int.h (target_ira_int): Rename x_move_cost to x_ira_register_move_cost, x_may_move_in_cost to x_ira_may_move_in_cost and x_may_move_out_cost to x_ira_may_move_out_cost. Delete the old fields with those names and also x_ira_max_register_move_cost, x_ira_max_may_move_in_cost and x_ira_max_may_move_out_cost. (move_cost, may_move_in_cost, may_move_out_cost) (ira_max_register_move_cost, ira_max_may_move_in_cost) (ira_max_may_move_out_cost): Delete. * ira.c (init_move_cost): Rename to... (ira_init_register_move_cost): ...this, deleting the old function with that name. Apply above variable renamings. Retain asserts for null fields. (ira_init_once): Don't initialize register move costs here. (free_register_move_costs): Apply above variable renamings. Remove code for deleted fields.

Ok. Richard, thanks for the patches which makes IRA code much more clear.

The divisions on the patches makes them easy to understand. The explanation what the patches are doing were excelent too.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]