This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [Patch] Bump minimum required MPFR version


On 05/07/2012 01:32 PM, Richard Guenther wrote:
> On Sun, May 6, 2012 at 7:24 PM, Janne Blomqvist
> <blomqvist.janne@gmail.com> wrote:
>> On Sun, May 6, 2012 at 2:39 PM, Richard Guenther
>> <richard.guenther@gmail.com> wrote:
>>> On Sun, May 6, 2012 at 10:33 AM, Janne Blomqvist
>>> <blomqvist.janne@gmail.com> wrote:
>>>> Hi,
>>>>
>>>> in http://gcc.gnu.org/install/prerequisites.html we say that GCC
>>>> requires at least MPFR 2.4.2, but in the toplevel configure.ac we only
>>>> require 2.3.1, printing a warning that the result is likely to be
>>>> buggy if the version is lower than 2.4.2.
>>>>
>>>> The attached patch bumps the minimum version to 2.4.0. We started
>>>> requiring 2.3.1, which was released on 2008-01-29, on 2009-04-08, that
>>>> is, about 1 year and a few months after the release. MPFR 2.4.0 was
>>>> released on 2009-01-26, so by now it's 3 years old. And by the time we
>>>> release 4.8 it's most likely over 4 years old already.
>>>>
>>>> For some background, the fortran frontend recently started using
>>>> mpfr_fmod to fix some bugs in the constant folding of the MOD and
>>>> MODULO intrinsics, effectively requiring at least MPFR 2.4.0 in order
>>>> to build.
>>>>
>>>> Also, if this patch is accepted the middle-end could be modified to
>>>> constant fold BUILT_IN_FMOD{F,,L} relatively easily, something which
>>>> isn't done today.
>>>>
>>>> Ok for trunk?
>>>
>>> Please make the check match documentation, thus 2.4.2, not 2.4.0.
>>
>> Something like the attached patch? FWIW, this removes the distinction
>> we have between "buggy, but builds" and "ok".
>>
>> Ok for trunk?
> 
> The change that bumped the documented requirement was logged with
> 
> +2010-01-31  Kaveh R. Ghazi  <ghazi@caip.rutgers.edu>
> +
> +       * doc/install.texi: Update recommended GMP/MPFR/MPC versions.
> 
> which suggests a recommended version.  So I'd revert my earlier comment
> and if 2.4.0 builds ok then we should check for that version instead.

The webpage disagrees.  Quoting
<http://gcc.gnu.org/install/prerequisites.html>:

======
MPFR Library version 2.4.2 (or later)
    Necessary to build GCC. It can be downloaded from
http://www.mpfr.org/. If an MPFR source distribution is found in a
subdirectory of your GCC sources named mpfr, it will be built together
with GCC. Alternatively, if MPFR is already installed but it is not in
your default library search path, the --with-mpfr configure option
should be used. See also --with-mpfr-lib and --with-mpfr-include.
=====

(for reference: mpfr 2.4.2 was released on 30 November 2009).

Cheers,
- Tobi
> 
> Thus, the earlier patch is ok.
> 
> Thanks,
> Richard.
> 
> 
> 
>> 2012-05-06  Janne Blomqvist  <jb@gcc.gnu.org>
>>
>>        * configure.ac: Bump minimum MPFR version to 2.4.2.
>>        * configure: Regenerated.
>>
>>
>>
>> --
>> Janne Blomqvist


-- 
Tobias Schlüter
Am Coulombwall 1, Zi. 317
85748 Garching b. München
Tel.: +49/89/289-14157


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]