This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [Patch] Bump minimum required MPFR version


On Sun, May 6, 2012 at 10:33 AM, Janne Blomqvist
<blomqvist.janne@gmail.com> wrote:
> Hi,
>
> in http://gcc.gnu.org/install/prerequisites.html we say that GCC
> requires at least MPFR 2.4.2, but in the toplevel configure.ac we only
> require 2.3.1, printing a warning that the result is likely to be
> buggy if the version is lower than 2.4.2.
>
> The attached patch bumps the minimum version to 2.4.0. We started
> requiring 2.3.1, which was released on 2008-01-29, on 2009-04-08, that
> is, about 1 year and a few months after the release. MPFR 2.4.0 was
> released on 2009-01-26, so by now it's 3 years old. And by the time we
> release 4.8 it's most likely over 4 years old already.
>
> For some background, the fortran frontend recently started using
> mpfr_fmod to fix some bugs in the constant folding of the MOD and
> MODULO intrinsics, effectively requiring at least MPFR 2.4.0 in order
> to build.
>
> Also, if this patch is accepted the middle-end could be modified to
> constant fold BUILT_IN_FMOD{F,,L} relatively easily, something which
> isn't done today.
>
> Ok for trunk?

Please make the check match documentation, thus 2.4.2, not 2.4.0.

Thanks,
Richard.

>
> 2012-05-06 ?Janne Blomqvist ?<jb@gcc.gnu.org>
>
> ? ? ? ?* configure.ac: Bump minimum MPFR version to 2.4.0.
> ? ? ? ?* configure: Regenerated.
>
>
> --
> Janne Blomqvist


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]