This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] Rename __gnu_slim_lto to __gnu_lto_slim
> On Sun, Oct 16, 2011 at 1:12 AM, Andi Kleen <firstname.lastname@example.org> wrote:
> > From: Andi Kleen <email@example.com>
> > Some external tools special case __gnu_lto* symbols, and the new __gnu_slim_lto
> > was the only LTO symbol not matching this pattern. Since I don't think
> > there are any users rename it to __gnu_lto_slim
> > Passes bootstrap and test suite on x86_64-linux. Ok?
This is fine, thanks! The intended use is for binutils to make linker/ar/nm warn
when they are run w/o plugin on slim objects and for linker plugin to make non-LTO
mode behave properly (i.e. fat objects the non-LTO way and slim objects always the LTO way)