This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Rename vshuffle/vec_shuffle to vec_perm


On Fri, Oct 7, 2011 at 3:49 PM, Richard Henderson <rth@redhat.com> wrote:
> Our existing vector permutation support uses the name vec_perm.
> The new support added for __builtin_shuffle used a variety of
> names. ?This brings all the internals into line with vec_perm.
>
> I've added documentation for the (existing) variable permute
> rtl named pattern (vec_perm). ?I've also added documentation for
> the (intended) constant permute rtl named pattern (vec_perm_const).
> I've not actually added the support for vec_perm_const yet, but
> plan to do so shortly. ?It was just easiest to do the docs for
> both at the same time.
>
> The builtin is still named shuffle in honor of the OpenCL primitive
> on which this feature is based. ?I've improved the documentation
> for the builtin a bit to make it clear that the selector modulus
> is part of the interface.
>
> Tested on x86_64-linux.
>

Is this a typo:

@@ -557,6 +560,7 @@ enum optab_index
 #define vec_pack_usat_optab (&optab_table[OTI_vec_pack_usat])
 #define vec_pack_sfix_trunc_optab (&optab_table[OTI_vec_pack_sfix_trunc])
 #define vec_pack_ufix_trunc_optab (&optab_table[OTI_vec_pack_ufix_trunc])
+#define vec_perm_optab (&direct_optab_table[(int) OTI_vec_perm])
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

 #define powi_optab (&optab_table[OTI_powi])




-- 
H.J.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]