This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Rename vshuffle/vec_shuffle to vec_perm


Our existing vector permutation support uses the name vec_perm.
The new support added for __builtin_shuffle used a variety of
names.  This brings all the internals into line with vec_perm.

I've added documentation for the (existing) variable permute
rtl named pattern (vec_perm).  I've also added documentation for
the (intended) constant permute rtl named pattern (vec_perm_const).
I've not actually added the support for vec_perm_const yet, but
plan to do so shortly.  It was just easiest to do the docs for
both at the same time.

The builtin is still named shuffle in honor of the OpenCL primitive
on which this feature is based.  I've improved the documentation
for the builtin a bit to make it clear that the selector modulus
is part of the interface.

Tested on x86_64-linux.


r~

Attachment: z
Description: Text document


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]