This is the mail archive of the
mailing list for the GCC project.
Re: [Ping] [patch 0/3] New macro PREFERRED_RENAME_CLASS
- From: Eric Botcazou <ebotcazou at adacore dot com>
- To: Yao Qi <yao at codesourcery dot com>
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Sat, 20 Nov 2010 11:17:41 +0100
- Subject: Re: [Ping] [patch 0/3] New macro PREFERRED_RENAME_CLASS
- References: <4CD24091.firstname.lastname@example.org>
> I sent three patches to add some logic in register-rename pass to prefer
> for different register classes. After some reviewers' review, three
> patches are updated and refactored like this,
> Patch 1: does everything except adding target hook
> preferred_rename_class . It is a separate improvement to register-rename.
> Patch 2: add target hook with doc, and use this hook in regrename.c
> Patch 3: it is arm specific patch.
> Middle-End maintainers,
> could you review patch 1 and patch 2?
Do you plan to follow up on this? I think it's a valuable improvement, worth
having in 4.6 and we are almost there implementation-wise.