This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

PATCH: Properly check glibc for x86_fallback_frame_state


Hi,

x86_fallback_frame_state only works with glibc newer than glibc 2.0.

!(__GLIBC__ == 2 && __GLIBC_MINOR__ == 0)

is true when __GLIBC__ isn't defined. This patch checks __GLIBC__.  OK
for trunk?

Thanks.


H.J.
---
2010-08-30  H.J. Lu  <hongjiu.lu@intel.com>

	* config/i386/linux-unwind.h (x86_fallback_frame_state): Properly
	check glibc.

diff --git a/gcc/config/i386/linux-unwind.h b/gcc/config/i386/linux-unwind.h
index 36ee370..415f7a3 100644
--- a/gcc/config/i386/linux-unwind.h
+++ b/gcc/config/i386/linux-unwind.h
@@ -106,7 +106,7 @@ x86_64_fallback_frame_state (struct _Unwind_Context *context,
    signal-turned-exceptions for them.  There's also no configure-run for
    the target, so we can't check on (e.g.) HAVE_SYS_UCONTEXT_H.  Using the
    target libc version macro should be enough.  */
-#if !(__GLIBC__ == 2 && __GLIBC_MINOR__ == 0)
+#if defined __GLIBC__ && !(__GLIBC__ == 2 && __GLIBC_MINOR__ == 0)
 
 #include <signal.h>
 #include <sys/ucontext.h>


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]