This is the mail archive of the
mailing list for the GCC project.
Re: ifcvt/crossjump patch: Fix PR 42496, 21803
- From: Eric Botcazou <ebotcazou at adacore dot com>
- To: Bernd Schmidt <bernds at codesourcery dot com>
- Cc: Paolo Bonzini <bonzini at gnu dot org>, gcc-patches at gcc dot gnu dot org, Steven Bosscher <stevenb dot gcc at gmail dot com>, Jim Wilson <wilson at codesourcery dot com>
- Date: Wed, 28 Jul 2010 10:35:41 +0200
- Subject: Re: ifcvt/crossjump patch: Fix PR 42496, 21803
- References: <4BB3CCCA.email@example.com> <firstname.lastname@example.org> <4C4F61A1.email@example.com>
> What exactly is gained by that? Certainly not readability.
Avoiding kludges like the one I already mentioned.
> You're moving insns, so reorder_insns is the correct API. The suggestion is
> obviously absurd in my eyes.
The first sentence is equally absurd these days because of CFG layout mode.