This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Add dg-require-linker-plugin


On Thu, Jul 22, 2010 at 4:45 PM, H.J. Lu <hjl.tools@gmail.com> wrote:
> On Thu, Jul 22, 2010 at 7:36 AM, H.J. Lu <hjl.tools@gmail.com> wrote:
>> On Thu, Jul 22, 2010 at 5:52 AM, Richard Guenther <rguenther@suse.de> wrote:
>>>
>>> This adds dg-require-linker-plugin support to the testsuite. ?Simple now,
>>> as the lto-plugin is installed into gcc/. ?I'll add the testcase for
>>> PR43373 as an example. ?Honza - you didn't yet apply the patch to
>>> fix the wrong-code issue of gcc.dg/lto/20100715-1_[01].c, so I won't
>>> commit that testcase now.
>>>
>>> Committed.
>>>
>>> Richard.
>>>
>>> 2010-07-22 ?Richard Guenther ?<rguenther@suse.de>
>>>
>>> ? ? ? ?* lib/target-supports-dg.exp (dg-require-linker-plugin): New proc.
>>
>> This adds dg-require-linker-plugin.
>>
>>
>>
>>> Index: gcc/testsuite/gcc.dg/lto/20100722-1_0.c
>>> ===================================================================
>>> *** /dev/null ? 1970-01-01 00:00:00.000000000 +0000
>>> --- gcc/testsuite/gcc.dg/lto/20100722-1_0.c ? ? 2010-07-22 14:36:20.000000000 +0200
>>> ***************
>>> *** 0 ****
>>> --- 1,6 ----
>>> + /* { dg-lto-do run } */
>>> + /* { dg-require-lto-plugin "" } */
>>
>> This uses dg-require-lto-plugin. Is this a typo?
>>
>
> I checked a fix to replace dg-require-lto-plugin with
> dg-require-linker-plugin.

Thanks.

Richard.

>
>
> --
> H.J.
>


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]