This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: Problem configuring uclinux toolchain


[Moving from gcc@ to gcc-patches@]

On 7/10/10 12:44 AM, Anthony Green wrote:
On 7/9/2010 11:59 AM, Maxim Kuvyrkov wrote:
On 7/9/10 3:22 PM, Anthony Green wrote:
Hi Maxim,

Recent changes to config.gcc are preventing me from building a
moxie-uclinux toolchain.

The following patch should fix the build of moxie-uclinux toolchain. The problem was that the piece of config.gcc defining supported linux C libraries isn't executed for most uclinux targets, moxie included. Still, many uclinux targets includes linux.h and linux.opt, which yielded an error.


The patch moves definitions of constants enumerating C libraries to top level and moves Android-specific definitions from LINUX_TARGET_OS_CPP_BUILTINS to ANDROID_TARGET_OS_CPP_BUILTINS.

Tested with arm-linux-androideabi build and partial moxie-uclinux build.

OK to apply?

--
Maxim Kuvyrkov
CodeSourcery
maxim@codesourcery.com
(650) 331-3385 x724

Attachment: android-uclinux-fix.ChangeLog
Description: Text document

Attachment: android-uclinux-fix.patch
Description: Text document


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]