This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]


Bernd Schmidt wrote:
On 04/28/2010 04:33 AM, Vladimir N. Makarov wrote:
On 04/27/2010 07:03 PM, Bernd Schmidt wrote:
That's the thing, there is only one way to define REG_ALLOC_ORDER since
it's an initializer.  If you need different ones depending on target
switches, as on ARM/Thumb, you need ORDER_REGS_FOR_LOCAL_ALLOC.  It's
just misnamed.  Even pre-IRA, it had an effect on both local and

Yes, I think it is better to rename the macro, e.g.
ORDER_REGS_FOR_ALLOC, because the current name is a misleading one.

Should I add a new target macro that decides whether to ignore those

Yes, probably introducing a new macro is a better solution.

How's this?

It is ok for me (assuming you will fix the IRA_HONOR vs HONOR confusion as you wrote in the next email). I only found that there are no changelog entries for other machine descriptions. It also would be nice to poison ORDER_REGS_FOR_LOCAL_ALLOC in system.h too as Joseph Myers proposed.

With these changes, it is ok for the trunk. Thanks for working on this issue, Bernd.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]