This is the mail archive of the
mailing list for the GCC project.
Re: IRA patch: use ORDER_REGS_FOR_LOCAL_ALLOC
On Wed, 28 Apr 2010, Bernd Schmidt wrote:
> > Yes, I think it is better to rename the macro, e.g.
> > ORDER_REGS_FOR_ALLOC, because the current name is a misleading one.
> >> Should I add a new target macro that decides whether to ignore those
> >> costs?
> > Yes, probably introducing a new macro is a better solution.
> How's this?
When renaming or removing target macros it's best to poison the old name
in system.h. This hasn't been done very consistently, but each such name
poisoned helps anyone updating a port done for an older version with the
old macro name.
Joseph S. Myers