This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: IRA patch: use ORDER_REGS_FOR_LOCAL_ALLOC


On 04/28/2010 04:33 AM, Vladimir N. Makarov wrote:
> On 04/27/2010 07:03 PM, Bernd Schmidt wrote:
>> That's the thing, there is only one way to define REG_ALLOC_ORDER since
>> it's an initializer.  If you need different ones depending on target
>> switches, as on ARM/Thumb, you need ORDER_REGS_FOR_LOCAL_ALLOC.  It's
>> just misnamed.  Even pre-IRA, it had an effect on both local and
>> global-alloc.
>>
>>    
> Yes, I think it is better to rename the macro, e.g.
> ORDER_REGS_FOR_ALLOC, because the current name is a misleading one.

>> Should I add a new target macro that decides whether to ignore those
>> costs?
>>
>>    
> Yes, probably introducing a new macro is a better solution.

How's this?


Bernd

Attachment: allocorder-v2.diff
Description: Text document


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]