This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: use -ftemplate-depth= instead of -ftemplate-depth-


On Sat, 20 Feb 2010, Manuel LÃpez-IbÃÃez wrote:
> Like it happened with Wlarger-than, ftemplate-depth does not follow
> usual GNU conventions for parameter switches. This patch fixes this
> but maintains that old option for backwards compatibility.

We also need to document this.  How about the following?

When did we change -Wlarger-than?  If with GCC 4.5, too, would you
mind adding a doc snippet, too?

Gerald

--- changes.html.orig	2010-04-04 12:33:15.000000000 +0200
+++ changes.html	2010-04-04 12:35:43.000000000 +0200
@@ -329,6 +329,10 @@
       new mangling is not on by default; users can activate it
       with <code>-fabi-version=4</code> or <code>-fabi-version=0</code>.
       <code>-Wabi</code> will now warn about code that uses the old mangling.</li>
+
+    <li>The command-line option <code>-ftemplate-depth-N</code> is now
+      written as <code>-ftemplate-depth=N</code> and the old form is
+      deprecated.</li>
   </ul>  
   <h4>Runtime Library (libstdc++)</h4>
 

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]