This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: RFA: hook doc patch (49/112): TARGET_SCHED_DFA_NEW_CYCLE


On Sun, 17 Jan 2010, Joern Rennecke wrote:
> I think with these name changes, the existing text becomes even worse 
> than it already is at making a connection between the parameters and 
> their semantics.

Well, you could also adjust the code and coin better variable names, not 
the least since you're not just documenting, but actually standardizing 
things by virtue of this patch.

(That said, reading your text I actually find it pretty clear.)

> I have attached a new patch which refers to the new names.

        * doc/tm.texi (TARGET_SCHED_DFA_NEW_CYCLE): Add argument names.         
        Rewrite text to refer to the names. 

This is okay, with the following changes:

 - "Instead of that" -> "instead"

 - I suggest swapping the second and third sentences, so that it
   becomes less ambigous when *@var{sort_p} is used (which I think
   is in general, not just when returning a value of zero), but it's
   your call.

 - How about changing "@var{dump} specifies the file to use for debugging
   output. The @var{verbose} parameter specifies the scheduler verbosity
   level of the debugging output." to

   "@var{dump} and @var{verbose} specify the file and verbosity level
   to use for debugging output."  ?  That looks shorter and easier.

Thanks again for taking the time to fix up the documentation, Jörn!

Gerald

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]