This is the mail archive of the
mailing list for the GCC project.
Re: [Ada] import handle_vector_size_attribute
Olivier Hainque <email@example.com> writes:
> Paolo Bonzini wrote:
>> >This annoying code duplication will hopefully go away when we reach
>> >agreement on the suggestion to globalize some attribute handlers, per
>> I think this patch is just waiting for approval (GWP unfortunately).
> My understanding as well. If need be, I'll of course be happy to
> rework as requested in addition to the libbackend changes we
> discussed already.
I thought there was going to be a modified patch incorporating Paolo's
suggestions, so I dropped the patch from my queue pending the followup.
I think Paolo is right: given your plan, attribs.c and the new file
should be in libbackend.a. That has no real cost that I can see.