This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: needed-list fails in libiberty


Eli Zaretskii <eliz@gnu.org> writes:

>> > 2009-04-14  Eli Zaretskii  <eliz@gnu.org>
>> >
>> > 	* Makefile.in (needed-list): Target removed (not used in GCC
>> > 	3.0 and later).  All references deleted.
>> 
>> This is OK if you've done a clean bootstrap on a primary platform.
>
> You mean, bootstrapping GCC?  Or something else?

Yes, bootstrapping gcc.  This is a normal requirement for a gcc patch,
as documented at http://gcc.gnu.org/contribute.html#testing .  My
concern here is merely to make sure that we aren't missing a hidden
dependency of libstdc++ on libiberty; such dependencies have certainly
been missed in the past.  For a patch like this only the libiberty
testsuite need be run.


> Would this platform be good enough?
>
>    Linux fencepost 2.6.16.29-xen #1 SMP Wed Dec 6 07:32:36 EST 2006 x86_64 GNU/Linux

Yes.  The current list of primary platforms may be found at
http://gcc.gnu.org/gcc-4.5/criteria.html .

Thanks.

Ian


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]