This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: needed-list fails in libiberty


On Tue, 14 Apr 2009, Eli Zaretskii wrote:

> The following snippet from libiberty/Makefile.in:
> 
>     # needed-list is used by libstdc++.  NEEDED is the list of functions
>     # to include there.  Do not add anything LGPL to this list; libstdc++
>     # can't use anything encumbering.

Since this comment relates to libstdc++ v2 and GCC 3.0 and later do not 
use this, removing all the obsolete code (and maybe everything relating to 
building a target libiberty) would be the obvious fix for any problems 
with it.

(As far as I can tell, the only use of any libiberty code for the target 
is libstdc++-v3 using a demangler source file; libiberty built for the 
target doesn't seem to be used at all.)

-- 
Joseph S. Myers
joseph@codesourcery.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]