This is the mail archive of the
mailing list for the GCC project.
Re: [lto] more fixes committed. now somethings even work.
- From: "Diego Novillo" <dnovillo at google dot com>
- To: "Kenneth Zadeck" <zadeck at naturalbridge dot com>
- Cc: gcc-patches <gcc-patches at gcc dot gnu dot org>, "Nathan Froyd" <froydnj at codesourcery dot com>, "Mark Mitchell" <mark at codesourcery dot com>, "Jan Hubicka" <jh at suse dot cz>
- Date: Sat, 20 Oct 2007 21:10:20 -0400
- Subject: Re: [lto] more fixes committed. now somethings even work.
- References: <email@example.com>
On 10/18/07, Kenneth Zadeck <firstname.lastname@example.org> wrote:
> 2007-10-18 Kenneth Zadeck <email@example.com>
> * tree-into-ssa.c (get_default_def_for, rewrite_stmt,
> maybe_register_def): Add cfun parameter to make_ssa_name.
When a basic helper needs to know what function it's acting on, we
have been adding functions with the same name and suffix
'_for_function' (e.g., n_edges_for_function,
While I think that suffix is too long, let's rename these functions
with the suffix _for_function and implement the original versions as a
call to the _for_function version with the 'cfun' argument.
For the long term, how about using '_fn' instead of '_for_function' as
suffix. Simply to make them shorter. Jan?