This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: PATCH: libgcc: Enable TLS for Linux/x86


On Thu, 5 Jul 2007, Daniel Jacobowitz wrote:

> Paolo, what about old binutils?  I don't know what we require nowadays
> but I doubt it's sufficient for __thread.  I think we still need a
> link test, or at least an assembler test.

install.texi says "As of GCC 3.3, binutils 2.13.1 or later is required for 
this platform." for i?86-*-linux*, with no specific version requirement 
mentioned for x86_64.  gcc/configure.ac believes that 2.14 has TLS support 
for both platforms.

(Maybe each GCC release should declare a minimum supported binutils 
version across all platforms - say the last FSF release as of when Stage 3 
is entered - and require that if you are using GNU binutils then you must 
use at least that version, rather than claiming probably untested support 
for random older versions.)

-- 
Joseph S. Myers
joseph@codesourcery.com


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]