This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

RE: PATCH: 4.3 bootstrap broken when configured as i386-linux


> -----Original Message-----
> From: H. J. Lu [mailto:hjl@lucon.org]
> Sent: Monday, March 26, 2007 2:06 PM
> To: Meissner, Michael; Andreas Schwab; Martin Michlmayr; Matthias Klose;
> gcc-patches@gcc.gnu.org
> Subject: Re: PATCH: 4.3 bootstrap broken when configured as i386-linux
> 
> On Mon, Mar 26, 2007 at 01:31:15PM -0400, Michael Meissner wrote:
> > On Mon, Mar 26, 2007 at 06:53:16PM +0200, Andreas Schwab wrote:
> > > "H. J. Lu" <hjl@lucon.org> writes:
> > >
> > > > There is nothing wrong to use AC_CANONICAL_SYSTEM for target
> > > > library.
> > >
> > > Actually there is, AC_CANONICAL_SYSTEM is obsolete.
> > >
> > > Andreas.
> > >
> > > --
> > > Andreas Schwab, SuSE Labs, schwab@suse.de
> > > SuSE Linux Products GmbH, Maxfeldstraße 5, 90409 Nürnberg, Germany
> > > PGP key fingerprint = 58CA 54C7 6D53 942B 1756  01D3 44D5 214B 8276
> 4ED5
> > > "And now for something completely different."
> >
> > Rather than using AC_CANONICAL and friends, a simpler patch follows.
> Any
> > comments on the patch, particularly from the libgcc maintainers?
> >
> >
> > libgcc/
> > 2007-03-26  Michael Meissner  <michael.meissner@amd.com>
> >
> > 	* configure.ac (--enable-decimal-float): Change x86 targets to
> > 	just x86_64*-linux* and i?86*-linux* so that a non-canonical
> > 	target of x86_64-linux will be handled.
> > 	* configure: Regenerate.
> >
> > --- libgcc/configure.ac.~1~	2007-03-24 13:25:28.593802000 -0400
> > +++ libgcc/configure.ac	2007-03-26 13:17:46.577488000 -0400
> > @@ -121,7 +121,7 @@ Valid choices are 'yes', 'bid', 'dpd', a
> >  ],
> >  [
> >    case $target in
> > -    powerpc*-*-linux* | i?86*-*-linux* | x86_64*-*-linux*)
> > +    powerpc*-*-linux* | i?86*-linux* | x86_64*-linux*)
> >        enable_decimal_float=yes
> 
> It won't work when configured as powerpc-linux, pentium4-linux, .....
> 
> 
> H.J.
> 

Yeah you are right.  I wondered whether I should have made powerpc*-linux as well, but since only x86 users were complaining, I tried to make the minimal patch.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]