This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: patch: New pragma command for gcc

On Mon, Mar 19, 2007 at 02:01:30PM +0100, Kai Tietz wrote:
> I corrected the coding style issue.

Not completely.

> And add a test-case to 
> gcc/testsuite/gcc.dg.
> ChangeLog:
> 2007-03-19      Kai Tietz <>

There should be 2 spaces after a date and 2 spaces between the name and
e-mail address.

>         * gcc/testsuite/gcc.dg/pragma-push_pop_macro.c: New case for 
> push_macro/pop_macro

Missing . at the end.  Also, as the ChangeLog for testcases is in
gcc/testsuite/, that prefix should be omitted.  Should be written as
	* gcc.dg/pragma-push_pop_macro.c: New testcase.

>         * gcc/c-pragma.c: Add new push_macro/pop_macro commands.

That doesn't describe what you actually changed:
	* c-pragma.c (handle_pragma_push_macro, handle_pragma_pop_macro):
	New functions.
	(sPragmaMacro): New typedef.
... etc.  You need to mention all functions/variables/etc. you have changed.

> Property changes on: pragma-push_pop_macro.c
> ___________________________________________________________________
> Name: svn:executable
>    + *

This is certainly undesirable.

> --- c-pragma.c	(revision 123058)
> +++ c-pragma.c	(working copy)
> +typedef struct sPragmaMacro GTY(())
> +{
> +  char *name;
> +  char *value;
> +  struct sPragmaMacro *prev;
> +} sPragmaMacro;
> +static GTY(()) struct sPragmaMacro *theMacroList = NULL;

CamelCase is not the standard GNU variable/type naming convention, see


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]