This is the mail archive of the
mailing list for the GCC project.
Re: VRP speedup
This should be return -2 (at least you check for that below and the
comment says so). The patch also looks more like a hack to me ;)
But I guess until someone fixes fold-const.c to provide a special
fold-to-constant for comparisons it's still ok.
What about a better name, e.g. operand_less_p?
/* Return true if value ranges VR0 and VR1 have a non-empty
! Benchmark compile/20001226-1.c compilation time after changing this
Btw - are these comment changes a reminder for youself? I don't think
they belong here (and above).
I think they do, if this is the heaviest code in 20001226-1.c right now.