This is the mail archive of the
mailing list for the GCC project.
Re: IPA merge part 1: localize SSA variables
> Jan Hubicka wrote on 11/15/06 16:40:
> >Maybe ;) but I am getting somewhat irritated by my own cgraph_ and
> >especially cgraph_varpool prefixes. Especially the second IMO just makes
> >code less readable by making it longer. My plan is to rename
> >craph_varpool into varpool as variables are not cgraph after all and I
> >am not sure what I was thinking about when I introduced it at first
> >Also I hope to have more clear split in between IPA infrastructure (ipa_
> >stuff), pass management and the cgraph datastructure itself that is all
> >somewhat intermixed right now in complettely misnamed cgraphunit.c...
> Well, but this is different, I think. For the cgraph functions you have
> a single name space, but with the ILs we have several name spaces that
> need to use the same terminology. We are also bound by a troglodytic
> implementation language, so there's little we can do.
This was my intention with cgraph/varpool too - to have two
datastructures with part of API symmetric (aka
cgraph_finalize/varpool_finalize, way to walk them and such) as for
large part of frontend functions and variables are the same, for most of
middle end the opposite is true.
But I guess we are again in agreement (I find myself writting GET_CODE
on trees and TREE_CODE on rtl quite often, symmetry would help)