This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: IPA merge part 1: localize SSA variables

On Wed, 2006-11-15 at 22:11 +0100, Jan Hubicka wrote:
> > Jan Hubicka wrote on 11/15/06 15:59:
> > >>Jan Hubicka wrote on 11/15/06 15:49:

> > >alternatively with the gimple_ prefixes or some other variant.
> > >
> > Well, I'm biased.  I kind-of like blah/set_blah, but I think I'm in the 
> > minority, so I won't push for it.
> I would vote for blah/set_blah too (for consistency and better
> extendability), so unless someone speaks out soon, I would go for it.
> > 

I have always preferred blah/set_blah.  It give you the ability to exert
better interface control, allowing easier changes under the covers down
the road.  It can also make finding bad sets easier when debugging :-).

> > Regarding the accessor name, might as well prefix them with gimple_
> This will imply more reformating for me, but it is definitly better to
> do it at once if there is overall plan for the prefixing.  Shorter
> prefix would be nice ;)

I think gimple_ is fine.  The only other alternative I can think of
would be the first letter, but g_df and r_df look too cryptic to me.
tree_ doesn't work since that would become tuples_ soon :-)


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]