This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: IPA merge part 1: localize SSA variables

> Jan Hubicka wrote on 11/15/06 16:11:
> >>Regarding the accessor name, might as well prefix them with gimple_
> >
> >This will imply more reformating for me, but it is definitly better to
> >do it at once if there is overall plan for the prefixing.  Shorter
> >prefix would be nice ;)
> >
> You are being lazy maybe?  :)  gimple has 3 more letters than rtl, yes 

Maybe ;) but I am getting somewhat irritated by my own cgraph_ and
especially cgraph_varpool prefixes. Especially the second IMO just makes
code less readable by making it longer.  My plan is to rename
craph_varpool into varpool as variables are not cgraph after all and I
am not sure what I was thinking about when I introduced it at first
Also I hope to have more clear split in between IPA infrastructure (ipa_
stuff), pass management and the cgraph datastructure itself that is all
somewhat intermixed right now in complettely misnamed cgraphunit.c...

> that's double the number of characters, but I can't think of anything 
> shorter that would make sense.

I can't come with something shorter either.
You should've been thinking about it when inventing the name. nRTL (new
RTL) would be two characters shorter. ;-) 
> So far it's just the two of us agreeing violently.  I'd like for other 
> folks to chime in.

Yep, this is precisely the sort of disucssion I hoped to have with those
interface changes, so I am really happy we started and we seems to agree


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]