This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Introduce abi_word_mode

Andreas Krebbel <> writes:
> I'm currently working on a s390 patch which needs gcc to 
> use internally a different word mode than the ABI-visible one.
> More precisely I want 32bit applications to 
> make use of 64bit registers without breaking the 32bit ABI. 
> I think the only target providing something like that is power
> currently.
> The problem with this is that gcc is not aware that there
> might be two different word modes one representing the actual
> register width and one to be used whenever the ABI comes into
> play. Ulrichs idea was to introduce an abi_word_mode to address
> this. As the name suggests this would be the mode to be used
> whenever a register or a register-size value is externally
> visible. For everything else word_mode is used as before.

I didn't see any follow-up to this message (apologies if there
was and I missed it), so FWIW...

You don't document your new UNITS_PER_ABI_WORD macro, and the
term seems a bit woolly.  What exactly do "word" and "abi word"
mean by your definition?  I think we need something fairly
clear-cut so that non-s390 maintainers can tell whether they
should be using word_mode or abi_word_mode.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]