This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] for PR 27735


> This does not test a well defined feature, it just happens to exercise a
> bug somewhere in the compiler.  In particular, it affects the generic
> code to do things in cfgloopmanip.
> Ergo, it should be named after the PR number.

I beg to differ: the testcase is essentially made up of a single loop exposing 
a blatant opportunity for unswitching with an irreducibility condition.  
Anyone implementing a loop unswitching pass would love to have such a 
testcase at hand.  So I think it deserves the loop-unswitch-?.c name.

-- 
Eric Botcazou


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]