This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] for PR 27735


Joseph S. Myers wrote:
> On Thu, 10 Aug 2006, Daniel Berlin wrote:
> 
>> You aren't in charge of maintaining the testsuite, so i'm not sure why
>> you are trying to change the way it's currently being done.  For
>> example, the only test in gcc.dg that contains information about who
>> reported is a single test from 2003.  There are plenty of tests that are
>> named after the PR number.
> 
> There are lots of tests with information about the reporter, e.g. 
> 20010622-1.c, enum-compat-1.c.  It just isn't any any particular format 
> you can conveniently grep for. 
I stand corrected then.


> codingconventions.html explicitly asks for 
> this:
> 
>    Where appropriate, testsuite entries should include comments giving
>    their origin: the people who added them or submitted the bug report
>    they relate to, possibly with a reference to a PR in our bug tracking
>    system. There are some copyright guidelines on what can be included in
>    the testsuite.

This i didn't notice.

> 
> sourcebuild.texi discusses naming:
> 
>    In general C testcases have a trailing @file{-@var{n}.c}, starting
>    with @file{-1.c}, in case other testcases with similar names are added
>    later.  If the test is a test of some well-defined feature, it should
>    have a name referring to that feature such as
>    @file{@var{feature}-1.c}.  If it does not test a well-defined feature
>    but just happens to exercise a bug somewhere in the compiler, and a
>    bug report has been filed for this bug in the GCC bug database,
>    @file{pr@var{bug-number}-1.c} is the appropriate form of name.
> 

This I did.
In the current case, Eric seems to be asking for the test to be named
after the pass that happens to trigger it, even though it does not test
a well defined feature (it's in generic loop manipulation code), which
means it should be named after the pr.

So uh, how is that not a change from our conventions?


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]