This is the mail archive of the mailing list for the GCC project.

Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [patch] for PR 27735

>> 	* gcc.dg/pr27735.c: New test.
> I'm from the old school so I think dg testcases should have a descriptive name 
> (for example loop-unswitch-1.c), explicitly mention the PR and have a header 
> acknowledging other contributions:
> /* PR rtl-optimization/27735 */
> /* Reported by dcb <> */
> /* Testcase by Andrew Pinski <> */

Please don't take this the wrong way (really!), but ....

You aren't in charge of maintaining the testsuite, so i'm not sure why
you are trying to change the way it's currently being done.  For
example, the only test in gcc.dg that contains information about who
reported is a single test from 2003.  There are plenty of tests that are
named after the PR number.

If we (the community of gcc developers we), or the testsuite maintainer,
want to change the naming and information contained in the tests from
what is currently being done, it should be discussed, not just asserted
as the way it should be done in a patch review and required of contributors.

(I have no problem with you requesting more in the areas you maintain
after discussion if that's what the consensus is, of course)


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]