This is the mail archive of the
mailing list for the GCC project.
Re: [patch] for PR 27735
- From: Zdenek Dvorak <rakdver at atrey dot karlin dot mff dot cuni dot cz>
- To: Eric Botcazou <ebotcazou at libertysurf dot fr>
- Cc: gcc-patches at gcc dot gnu dot org
- Date: Thu, 10 Aug 2006 12:38:26 +0200
- Subject: Re: [patch] for PR 27735
- References: <20060524095159.GA14182@atrey.karlin.mff.cuni.cz> <firstname.lastname@example.org>
> > * cfgloop.h (fix_loop_placement): Declaration removed.
> > * loop-unswitch.c (unswitch_loop): Do not call fix_loop_placement.
> Does this change belong here?
yes (the arguments of fix_loop_placement changed, so this spot needs to
be changed; and I noticed that in fact the fix_loop_placement calls are
in fact not needed here, since remove_path calls fix_loop_placement if
> > * gcc.dg/pr27735.c: New test.
> I'm from the old school so I think dg testcases should have a descriptive name
> (for example loop-unswitch-1.c), explicitly mention the PR and have a header
> acknowledging other contributions:
> /* PR rtl-optimization/27735 */
> /* Reported by dcb <email@example.com> */
> /* Testcase by Andrew Pinski <firstname.lastname@example.org> */
Is there some document specifying how the testcases should look like?
Otherwise, it does not make much sense to me to require one ad-hoc
convention over another ad-hoc convention.
I will send updated patch once it is tested.