This is the mail archive of the
mailing list for the GCC project.
Re: [patch] for PRs 27639 and 26719
- From: Mark Mitchell <mark at codesourcery dot com>
- To: Zdenek Dvorak <rakdver at atrey dot karlin dot mff dot cuni dot cz>
- Cc: Ian Lance Taylor <iant at google dot com>, Eric Botcazou <ebotcazou at adacore dot com>, Richard Guenther <rguenther at suse dot de>, gcc-patches at gcc dot gnu dot org, sebastian dot pop at cri dot ensmp dot fr
- Date: Wed, 05 Jul 2006 22:50:42 -0600
- Subject: Re: [patch] for PRs 27639 and 26719
- References: <20060520192624.GA28713@atrey.karlin.mff.cuni.cz> <email@example.com> <20060626212619.GA800@atrey.karlin.mff.cuni.cz> <firstname.lastname@example.org> <20060626230656.GA24710@atrey.karlin.mff.cuni.cz> <20060628040144.GA6271@atrey.karlin.mff.cuni.cz> <email@example.com> <20060705204717.GA17429@atrey.karlin.mff.cuni.cz>
Zdenek Dvorak wrote:
> I prefer the current name (or some variant of it, if the current name
> seems unclear to you); it tells what property the function tests for (a
> scalar type in that the arithmetics cannot be performed).
However, "arithmetic type" is a defined term in C++ (and perhaps in C).
It would be a bad idea to use nonarithmetic_type as the name of the
predicate, since that would cause people to think it had the defined
(650) 331-3385 x713