This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] Bootstrap currently broken due to unsigned comparison warning in calls.c


On Monday, July 25, 2005, at 08:59 AM, Jakub Jelinek wrote:
Oops, sorry.  Not sure why -Werror has not been used in my bootstrap
this time, will investigate.

I'm thinking that we should enable -Werror for all non-release builds when the first two numbers in the version string match between the compiler used to build and the version of gcc that we are building. The idea is that most developers install and use a new enough compiler that most of the time this would be true.



Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]