This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] MIPS32 DSP intrinsics
"Chao-ying Fu" <firstname.lastname@example.org> writes:
>>> + #define CODE_FOR_mips_addq_s_ph CODE_FOR_mips_addsv2hi3
>>> + #define CODE_FOR_mips_addq_s_w CODE_FOR_mips_addssi3
>> ...stuff like this shouldn't be necessary. Just give the .md pattern
>> the name you want.
> Because I use macro in "mips-dsp.md", some auto-generated instruction
> names are not what I want. Thus, I need to have these defines.
Can you explain? It should be possible to get any name you want
in the .md file, even using macros. (There's no requirement for
the pattern name to include "<mode>", in case that's what you're
> But, I can remove "RejectNegative" to create "-mno-dsp", if this is better.
I think it'd be more consistent to have -mno-dsp, much like we have
-mno-mips16 and various other -mno options. For example, it can
sometimes be useful to take a command line that includes "-mdsp"
and just stick a "-mno-dsp" at the end to override it.
FWIW, I see RejectNegative as being for things that aren't boolean
switches (e.g. -mflush-func), for cases whether the negative isn't
"-mno" (e.g. -msoft-float/-mhard-float) and for cases where the
option is sort of an enum (-mgp32, -mgp64).