This is the mail archive of the
mailing list for the GCC project.
Re: [committed] Fix problem with the rename of pp_format_text to pp_format in the java front-end
- From: Gabriel Dos Reis <gdr at integrable-solutions dot net>
- To: Zack Weinberg <zack at codesourcery dot com>
- Cc: Andrew Pinski <pinskia at physics dot uc dot edu>, GCC Patches <gcc-patches at gcc dot gnu dot org>, alanm at gcc dot gnu dot org, GCJ Patches <java-patches at gcc dot gnu dot org>
- Date: 01 Jul 2005 17:14:19 +0200
- Subject: Re: [committed] Fix problem with the rename of pp_format_text to pp_format in the java front-end
- References: <email@example.com><firstname.lastname@example.org>
Zack Weinberg <email@example.com> writes:
| Andrew Pinski <firstname.lastname@example.org> writes:
| > This fixes the problem with compiling the java front-end.
| This is, sadly, not a complete fix. pp_format() does not produce
| output; you need to call pp_output_formatted_text() too. (The name is
| confusing, yes; feel free to rename it to something more sensible, if
| you can think of one.) See pretty_print.c:pp_printf() for the proper
| way to do it.
Part of what made reviewing your change difficult was the
implementation of intended semantics combined with renaming. In
retrospect, those renamings should have been kept to the minimum, not
just you did not like them.