This is the mail archive of the
mailing list for the GCC project.
Re: [PATCH] PR19331: Improve RTL bit-field simplification (take 2)
On Mon, Feb 07, 2005 at 09:07:54AM -0700, Roger Sayle wrote:
> If you'd prefer, I can prepare a follow-up patch to replace the above
> uses with "simplify_gen_subreg (..., subreg_lowpart_offset (...))"
I'd certainly like to know if that works. I know there are subtle
differences between all of these functions.
> (including the instances in simplify_binary_operation)?
> Perhaps we could even add a "simplify_gen_lowpart (mode, x)"?
There's already a "lowpart_subreg", whose name I find disturbing.
Certainly that's a better name. And would be better placement than
randomly in the middle of the loop code.