This is the mail archive of the gcc-patches@gcc.gnu.org mailing list for the GCC project.


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]
Other format: [Raw text]

Re: [PATCH] FOR_EACH_RTX construct to replace for_each_rtx


On Thu, Jan 20, 2005 at 09:09:35AM +0100, Paolo Bonzini wrote:
> Keeping the for_each_rtx idiom of using global variables or 
> structs-for-parameters (a la replace_label) would not have improved 
> readability.

But would have simplified reviewing the patch.  Full transition
to some other form should happen in stages.  Not all at once.


r~


Index Nav: [Date Index] [Subject Index] [Author Index] [Thread Index]
Message Nav: [Date Prev] [Date Next] [Thread Prev] [Thread Next]